» Part of Wolfey's Website

"Home" Work (Well, Close…)

May 20, 2008 at 9:51 PM

In order to collect my unemployment compensation, I had to go down to the local CareerLink on May 8 - it was basically a "class" to help those of us who were unemployed find work, both through CareerLink and by other means. At least now I can get my money for unemployment =)

However, that's not going to matter that much as of late, because my break is over and I'm no longer unemployed - I'm back to work.

First, though, here's what has been going on lately:

(more...)

‘top Transposition, Then Tuneup

May 18, 2008 at 7:05 PM

After I got my new computer working, I started to take care of a few things with my older ones =)

Rather than wait until after I got all my files transferred to switch my new and previous desktops around, I switched them around when my parents were gone last week. It took awhile to untangle the cables before moving them, as well as minimizing future entanglement afterwards, but I got it all taken care of. After doing that, I set up my stuff on my new desktop, but left my parents' stuff on the previous desktop for now. The new system runs so much faster in places =D

Then, I got to work on my laptop: since there was nothing important on it (or so I thought), I decided to start anew - I formatted and (re)partitioned the drive, reinstalled Windows and Ubuntu (in that order) and took care of getting them both updated. Hopefully I'll be able to get into using it this time, as it's been sitting around for quite awhile. At the moment, I'm missing a few drivers for Windows and will have to look around for them, as I never got a drivers disc and do not know the exact driver names (I knew I forgot something important...). After hooking up a spare network cable and letting the "Hardware Update Wizard" search Windows Update for drivers, I managed to get one for the wireless card. Unfortunately, Windows Update didn't have any of the other ones, especially for the monitor - things are slightly blurry as the resolution's lower than what it should be, which I can't fix without the right driver =(

Then, on the new desktop, I set up a program called The Font Thing to better manage what fonts I'm using, as it can:

  • Show a list of font names, font filenames and whether or not they're currently installed,
  • Allow for quick installation/uninstallation of fonts,
  • Save a list of fonts as a "collection", allowing for quick installation/uninstallation of a specific set of fonts,
  • Show some sample text using that font, to quickly preview how it will look (regardless of whether or not the font is installed), and
  • Allow the user to type in some text - and even set its size - to see exactly what the font will look like when in use.

On my previous desktop, I ended up installing hundreds of fonts (literally - there's 300-400 fonts I had installed that weren't there by default) just to make sure I had the ones I needed, which were a handful out of that list. Having all these fonts installed at once is probably partly responsible for the slowdown of many applications (and the OS itself) on my previous computer, and that's why I'm using a separate program to manage them now - it should be much easier to work with them, especially since I can see what they'll look like before installing them and can install/uninstall a specific set at any time.

For that matter, I'm going to have to get the previous desktop back into working shape for my parents to use: I'll have to back up its contents, format the drive, reinstall Windows and only install the programs my parents will need, to ensure this won't happen again. Installing a lot of programs (and fonts) seemed like a good idea at the time, but it just caused more problems than it solved.

For the new desktop and (to a lesser extent) the laptop, I will be using VirtualBox, Virtual PC and VMWare Player for testing applications to see if they'll work properly on a virtual copy of the OS before installing them on the actual OS, as well as to get just the files I need from self-extracting executables (since they tend to create a lot of clutter in the process).

If all goes well, I'll be able to spend less time maintaining my computers and more time working on my projects =)

Better Late than Never…

May 17, 2008 at 1:46 PM

I just had to wait a little longer: on the day after my birthday, my computer finally arrived =D

Unfortunately, it was just the computer - my flash drives, video card and speakers didn't come with it =(

The mouse that came with it was just a regular mouse (two buttons plus the wheel), so I'll be using the spare one I mentioned about earlier. The recycling "package" was just a large mailing envelope with some shipping labels and instructions on what to do - I'll have to find two spare boxes somewhere for shipping the old computer, since I won't be able to ship them in the same box given their size (and weight, in the case of the monitor).

I hooked up what I had, started it up, and was surprised at how loud the tower was - it's actually very quiet, aside from the short (but still relatively quiet) burst of noise when it starts up. After going through the initial setup process, I shut it down, unplugged all of the cables, opened the side of the case and swapped out the two 512 MB sticks of RAM for four 1 GB sticks of RAM. Unlike every other time I've had to mess around with RAM, it took quite a bit of force to push them in...but at least I won't have to add any more in the future. After that, I put the side of the case back on, plugged all of the cables back in, and started it up again - it's working great so far.

...

Oh, remember what I said earlier, about just having to wait a little longer? Well, aside from getting a few more cards over the next few days, I also got the remaining parts: the flash drives arrived the day after I got my computer, and the speakers and graphics card came in the day after that =D

The subwoofer was heavy...and had a few more connections than my previous one - the same went for the speakers. Once I got them hooked up, I went to put in the graphics card before starting the system up.

The graphics card was bigger than I thought - half of its depth was from the heatsink alone, which caused the entire card to take up two card spaces in the back. On the other hand, it seems this type of motherboard was made to take this into account - the slot for the card fit properly (though I had to push it in a bit, to properly lock around the little "clasp" piece at the end of the slot, which I've never seen for a card before); the slot for the heatsink, however, was really small - I assume it's for cards which have a second piece to connect to the board, since my card didn't have that piece. The ports (two DVIs, one S-Video) were visible from the one opening in the back, while part of the heatsink was visible from the other opening.

Prior to getting the new card, I used the original VGA connection, which was getting some odd kind of interference during use - it was most noticeable around the icon text (white text on a dark gray background, which was the "Inspiron" wallpaper installed by default on the system), but went away after awhile...and came back if the monitor was off (well, in sleep mode) for awhile. After putting in the new card, I decided to switch out the VGA cable for a DVI cable (both came with the monitor) - it was a tight squeeze since the plug is slightly longer, but after starting up the system, the "interference" problem was gone! The screen resolution was reset, but that didn't worry me - I expected that would happen, and could be fixed after installing the drivers (which, after doing so, automatically offered to set the resolution back to its highest, which is what I had originally set it to). Also, the contrast appears much better with the new connection for some reason - in one case, I had an image that looked just white with the VGA connection, but is actually white with a few very light (but clearly visible) colors with the DVI connection. If the DVI connection really makes that much of a difference, I'm going to see about getting a similar graphics card (with a DVI connection) for my previous computer.

Back to the speakers: once I got the graphics card in, I plugged in the speakers (which gave off a fairly loud "pop" - it does this every time it's turned on and is something my previous computer's speakers didn't do), plugged the audio jack into the computer, and started it up. After taking care of the graphics card setup, I tried finding something to play on the speakers - Mom suggested a song she downloaded. I played it, followed by adjusting the speaker volume (and subwoofer volume, both controlled from the right speaker), and both of us thought it sounded good - Mom said she thought she could feel the floor vibrating just a bit from the subwoofer's bass (pretty good for the subwoofer, considering it sat on the carpeted part of the floor).

I also noticed a few nice things for sound control: the multimedia keyboard had controls for sound (a dial for volume, plus a button to mute volume entirely), stop/play/pause/rewind/fast-forward buttons for playback, a "music" button (which I haven't figured out the purpose of yet) and the right speaker had two audio jacks - one which shuts off and redirects sound from the speakers (for use with headphones) and one which lets the sound from the computer continue playing (for use with music players). It also had controls for web browsing and common functions ("My Computer" and the calculator)...though I doubt those will be used as much.

So far, the system's been working great! =D

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.5 License. | Wolfey's Weblog